Paypal error

Hi.

I installed ""Paypal standard"" module in my LC installation.

After configuring, the order goes to Paypal and I pay without problems, but when Paypal gives the connection back to LC, I always get the same message:

Could not verify the Paypal transaction as no payment data was returned

I tried with the sandbox and production.

I'm using 1.3.3.1 version and 1.2 into the module.

What am I doing wong?
Hi.

I've been checking, but rm seems to be ok.

This is what I have in this section:

 $fields = array(

        'cmd'           => '_cart',

        'bn'            => 'Lite_Cart',

        'upload'        => '1',

        'rm'            => '0',

        'business'      => $this->settings['merchant_email'],

        'currency_code' => !empty($this->settings['use_store_currency']) ? settings::get('store_currency_code') : $order->data['currency_code'],

        'cbt'           => language::translate(__CLASS__.':title_finalize_order', 'Finalize Order'),

        'return'        => document::ilink('order_process'),

        'cancel_return' => document::ilink('checkout'),

        //'notify_url'    => document::ilink('callback', array('order_uid' => $order->data['uid'])), // We're not using IPN callbacks

        'charset'       => language::$selected['charset'],

        'custom'        => $order->data['uid'],
Everything looks right
Could this problem be linked with this?

https://www.litecart.net/forums/7/add-ons/2744/paypal-addon-new-configuration
I don't think so, as that thread has some rewritten version of the module. Do you have any HTTP access logs? We want to find out if paypal did include the HTTP GET params in the returning request.
Hi.

That's what I could find :

62.82.58.246 - - [03/Nov/2015:13:21:56 +0000] "GET /ext//select2/select2.min.css HTTP/1.0" 200 641 "https://mydomain.com/es/checkout" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0"

62.82.58.246 - - [03/Nov/2015:13:21:57 +0000] "GET /ext//select2/select2.min.js HTTP/1.0" 200 647 "https://mydomain.com/es/checkout" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0"

62.82.58.246 - - [03/Nov/2015:13:21:57 +0000] "GET /ext//select2/i18n/es.js HTTP/1.0" 200 1064 "https://mydomain.com/es/checkout" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0"

62.82.58.246 - - [03/Nov/2015:13:21:57 +0000] "GET /cache/c839cf3ca4849852cff7bb0948e130c03beb7676320x320_fwb.jpg HTTP/1.0" 200 522 "https://mydomain.com/es/checkout" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0"

62.82.58.246 - - [03/Nov/2015:13:21:57 +0000] "GET /cache/a2dcaa0661dd93c5b7faca9c90d572ab185098fc200x70_fobws.png HTTP/1.0" 200 522 "https://mydomain.com/es/checkout" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0"

62.82.58.246 - - [03/Nov/2015:13:21:57 +0000] "GET /cache/349dad003399308173f7f6c4273406f3108af35c200x70_fobws.png HTTP/1.0" 200 522 "https://mydomain.com/es/checkout" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0"

62.82.58.246 - - [03/Nov/2015:13:22:01 +0000] "GET /es/ HTTP/1.0" 200 4918 "https://mydomain.com/es/checkout" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0"

62.82.58.246 - - [03/Nov/2015:13:22:11 +0000] "POST /es/login HTTP/1.0" 302 986 "https://mydomain.com/es/" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0"

62.82.58.246 - - [03/Nov/2015:13:22:11 +0000] "GET /es/ HTTP/1.0" 200 4727 "https://mydomain.com/es/" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0"

62.82.58.246 - - [03/Nov/2015:13:22:14 +0000] "GET /es/checkout HTTP/1.0" 200 12210 "https://mydomain.com/es/" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0"

62.82.58.246 - - [03/Nov/2015:13:22:21 +0000] "POST /es/order_process HTTP/1.0" 200 2198 "https://mydomain.com/es/checkout" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0"

62.82.58.246 - - [03/Nov/2015:13:26:04 +0000] "GET /es/order_process HTTP/1.0" 302 2270 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0"

62.82.58.246 - - [03/Nov/2015:13:26:04 +0000] "GET /es/checkout HTTP/1.0" 200 12345 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0"

62.82.58.246 - - [03/Nov/2015:13:26:05 +0000] "GET /ext/fontawesome/fonts/fontawesome-webfont.woff2?v=4.4.0 HTTP/1.0" 200 453 "https://mydomain.com/ext/fontawesome/css/font-awesome.min.css" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0"
There is nothing indicating there was a returning user from Paypal. The following request should have carried the returning HTTP GET parameters.

62.82.58.246 - - [03/Nov/2015:13:26:04 +0000] "GET /es/order_process HTTP/1.0" 302 2270 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0"
Hi.

After install 1.2.1 version, the previous error dissapears, but now I have a new one:

 Payment currency () should have been EUR

I have checked the paypal account, and currency is Euro.

I also created a "customer" account in Euro.

Could you help me?
Your $txdata did not have a value for the currency code, see $txdata['mc_currency'] row 208 in the latest version. https://www.litecart.net/addons/5/paypal

What does this show:

var_dump($txdata);exit;