Can't install module

Hi,
I followed your instructions to install Google Analytics module, but I can't activate it (see image).

My litecart version is LiteCart 2.1.5

Kind regards

Nicola
Your screen is too small or the page gets too long. Zoom out one step in your browser. The name of the module should be shortened for any future version.
Hi Tim,

here is another screenshot.

Kind regards
Nicola
That one looks better. Now click Install to the right.
So easy: I should have checked before!

Thank you Tim