Featherlight box : a small bug with iframe ?

Hi

I have discovered what looks like a Featherlight's bug.

Look at this picture.
Apparently, if the first <a data-toggle="lightbox" found in the DOM is data-type=iframe, all the following will keep open in iframe....i.e: B also, in the picture, which should not.

If I remove A, then, ok, B opens a classic non-iframed lightbox and C a iframed one.

Understanding Featherlight's js is out of my current skills.

So any help is welcome.
Regards
Make sure you don't have an anchor tag inside another anchor tag.

You could try replacing the component with the original Featherlight found on Github. It is possible the LiteCart edition contains an issue.

If you edit func_draw.inc.php you can easily replace the lightbox with some other third party contribution.
Yes, I have checked this. There are no embedded anchor.
Make sure you don't have an anchor tag inside another anchor tag.


Also tried without any success
You could try replacing the component with the original Featherlight found on Github. It is possible the LiteCart edition contains an issue


.
Ok, found: data-type MUST be specified for each anchor since any parameter's value which is not re-defined will be taken from first prototype as default.
So I suggest you to add it to each anchor in further litecart releases
He another alternative solution...(featherlight.js)
I thought that if data-type is not defined that it would use the library's default setting. You are saying that it takes the first defined element and use that for default? I have too much work right now to find out for myself. I see your screenshot there which looks like you might be right.