Home page (catalog) not showing up on server

I cannot get my website to display after installing Litecart version 2.1.2

I still have the index.html page that came by default with my web hosting for the domain.

I can see the admin page by typing "/admin_folder" as a subdirectory in the URL.

I've added a sample product to the catalog, disabled the default ones, then enabled the default ones again hoping to get something working.

When I click the "catalog" button from the admin page, the browser goes to "www.my_domain.com/en" where I'm getting a File not found message. There is no folder named /en on my server.
Remove the index.html file, it is propabably first in order that the daemon looks for.

Second, it seems mod_rewrite is not supported. Without that support /en/ will be reuired to be /index.php/en/. Enable it or remove the lines in lib_route.inc.php that tells litecart to rewrite the urls.

    // Detect URL rewrite support
      $use_rewrite = false;
      if (isset($_SERVER['REDIRECT_HTTP_MOD_REWRITE']) && in_array(strtolower($_SERVER['REDIRECT_HTTP_MOD_REWRITE']), array('1', 'active', 'enabled', 'on', 'true', 'yes'))) {
        $use_rewrite = true;
      } else if (function_exists('apache_get_modules') && in_array('mod_rewrite', apache_get_modules())) {
        $use_rewrite = true;
      } else if (!preg_match('#(apache)#i', $_SERVER['SERVER_SOFTWARE'])) {
        $use_rewrite = true; // We are just going to assume any non-apache HTTP daemon supports URL rewriting
      }
Replace with

      $use_rewrite = false;
Can I built the site on the demo, or must I install it on a server first?
Could somebody help me to install it?
Okay, I removed index.html and made the changes to lib_route.inc.php.

I still have no folder /en and the site launches with a "restricted area" login.

Would it be better if I delete everything from the server and start with a fresh install?